Version 2.4 is our latest release.

Mac OS X

OS X 10.7 (Lion) and newer ships with Apache and PHP pre-installed. Recent versions of OS X include PHP 5.4. On the other hand, MySQL can be installed using the official package.

However, we encourage you to use homebrew, an open source package manager for OS X that will make the installation of the dependencies and its maintenance much easier. Installing homebrew is easy:

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go/install)"

Note that Xcode is required, which you can download from the App Store. More instructions can be found at: https://github.com/mxcl/homebrew/wiki/Installation

Once homebrew and Xcode are installed, you are ready to install all the packages needed:

brew install php54 --with-mysql --with-fpm
brew install nginx
brew install elasticsearch
brew install mysql55

Some extra dependencies can be also be installed via homebrew:

brew install ffmpeg
brew install imagemagick
...

Version 2.4

Contents