Version 2.4 is our latest release.

Technical Requirements

Server-side requirements (for installation, hosting, etc.)

Details for the hardware and server environment, and the software dependencies (both required and recommended) have been documented in our Administator Manual. For further details, see: Requirements.

Client-side requirements (for end users)

AtoM has been designed with minimal assumptions about the technology available to users and contributors. All that is required is access to the internet and a web browser (any web browser will do, though use of a modern web browser is strongly encouraged). AtoM does, however, rely on “client-side” JavaScript to achieve certain effects when displaying content:

  • on edit pages, fields are grouped into information areas that are “collapsible” (i.e., fields can be displayed or hidden)
  • Some drop-down menus are collapsible (i.e. options in the list can be expanded to display more options or collapsed to hide them)

Older browsers that do not support JavaScript will not be able to view these effects. They are still able to access AtoM unimpaired; it just won’t look as nice. It is recommended, therefore, that users employ modern web browsers that support JavaScript (such as Firefox, Chrome, Opera, or Safari.)

The digital object multi-uploader requires Flash. This is a requirement that we are hoping to eliminate in future releases.